Hello and welcome to our community! Is this your first visit?
Register
Reigster at Galaxy S3 Forums
Page 1 of 2 12 LastLast
Results 1 to 10 of 17
Like Tree2Likes

Thread: Stop Home key from waking screen

  1. #1
    Senior Member Eric's Avatar
    Join Date
    Jun 2012
    Location
    Southern California
    Posts
    384
    Member #
    309
    Liked
    57 times

    Stop Home key from waking screen

    **Must have root**

    As the title says, stop your home key from waking your device.....(then only power button wakes it up )

    you can do this simply with root explorer https://play.google.com/store/apps/d...RleHBsb3JlciJd.
    (THERE ARE OTHERS TO USE MAYBE EVEN FREE, THIS IS ALL I HAVE EVER USED IS ALL)

    ONLY MODIFY THE FILE SPECIFIED!
    OR PLAY AROUND AT YOUR OWN RISK AS NOTHING OTHER THAN MENTIONED FILE IS TESTED....



    open root explorer

    navigate to : system/usr/keylayout
    now press the mount r/w button near the top of screen to enable read and write permissions

    scroll down to: sec_keys.kl
    press and hold until menu pops up, select: Open in Text Editor

    locate line: key 172 HOME WAKE

    tap behind the word WAKE and delete it so you see: key 172 HOME

    press menu and select: Save and Exit

    now press the button at the top of the screen to disable read and write permissions: Mount R/O
    (once pressed should now read : Mount R/W again.

    Exit root explorer

    Reboot your phone

    see if it works

    Last edited by Eric; 08-02-2012 at 12:46 PM. Reason: defined why for lol...

  2. #2
    Senior Member Debian Dog's Avatar
    Join Date
    May 2012
    Location
    Powhatan, VA
    Posts
    817
    Member #
    179
    Liked
    164 times
    Twitter
    DebianDog
    Then how do you wake it?

  3. #3
    Senior Member greevedogg's Avatar
    Join Date
    Jun 2012
    Posts
    178
    Member #
    233
    Liked
    29 times
    Then only the power button on the side will wake the phone, I'm guessing...

    I personally, use the home button to wake my phone most of the time.

  4. #4
    Senior Member Eric's Avatar
    Join Date
    Jun 2012
    Location
    Southern California
    Posts
    384
    Member #
    309
    Liked
    57 times
    yes.... power button only.


    i personally have serious issues constantly hitting the home button while its in my pocket and want only the power button to wake the screen.
    UltraDroid likes this.

  5. #5
    Senior Member Ollie's Avatar
    Join Date
    May 2012
    Posts
    2,201
    Member #
    17
    Liked
    272 times
    Volume Up for me wakes the phone. That with No Lock brings me straight to my home screen.

    Sent from my GT-I9300 using Tapatalk 2

  6. #6
    Administrator CR6's Avatar
    Join Date
    May 2012
    Location
    Idaho
    Posts
    17,516
    Member #
    19
    Liked
    9953 times
    Device
    other
    I like that the home screen wakes the phone. Never had a problem with it opening while in my pocket. (yet) I'm sure it'll start happening now!!

  7. #7
    Senior Member Debian Dog's Avatar
    Join Date
    May 2012
    Location
    Powhatan, VA
    Posts
    817
    Member #
    179
    Liked
    164 times
    Twitter
    DebianDog
    Quote Originally Posted by Ollie View Post
    Volume Up for me wakes the phone.
    Odd mine only wakes up on Home or Power

  8. #8
    Senior Member Ollie's Avatar
    Join Date
    May 2012
    Posts
    2,201
    Member #
    17
    Liked
    272 times
    Quote Originally Posted by Debian Dog View Post
    Odd mine only wakes up on Home or Power
    It's cause I am romming

    Sent from my GT-I9300 using Tapatalk 2

  9. #9
    Senior Member Eric's Avatar
    Join Date
    Jun 2012
    Location
    Southern California
    Posts
    384
    Member #
    309
    Liked
    57 times
    I must say, now my pocket stays much cooler at work... My chapstick hasn't melted at work yet tonight lol!

  10. #10
    Junior Member dohse's Avatar
    Join Date
    Jul 2012
    Posts
    2
    Member #
    720
    Didn't work for me. I deleted WAKE from line 172, hit save and exit, etc, reboot . . . and the home button wakes the screen after a slight delay. :/

    Edit - and after a few more reboots for CW backups it seems to be working as it should. Weird, but thanks!
    Last edited by dohse; 07-20-2012 at 11:18 AM.


 
Page 1 of 2 12 LastLast

Remove Ads

Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Any way to change "double tap home" to do google voice search?
    By durantula35 in forum Galaxy S3 General Discussion
    Replies: 12
    Last Post: 10-14-2012, 09:35 AM
  2. Warning! Don't try this at home!
    By BrownstotheBone in forum Off Topic Forum
    Replies: 18
    Last Post: 07-03-2012, 08:09 AM
  3. Cant stop apps from running in the background
    By Gooberman in forum Galaxy S3 Help
    Replies: 15
    Last Post: 06-21-2012, 02:18 PM
  4. Black screen
    By Gooberman in forum Galaxy S3 Help
    Replies: 21
    Last Post: 06-18-2012, 05:05 AM
  5. How is the default Launcher/Home? Apex?
    By Debian Dog in forum Galaxy S3 General Discussion
    Replies: 11
    Last Post: 06-14-2012, 07:40 PM

Search tags for this page

disable home button sansung s3

,

disable home button wake galaxy s5

,
dont allow screen to turn on when home button pressed s5
,
galaxy a3 home button disable wake up
,

galaxy s3 disable home button unlock

,

galaxy s5 disable home button wake

,
how to make samsung devices not wake up with home button
,
how to prevent the home button from turning on samsung s3
,
how to usr home button on s5 to wake up phone
,
s5 stop home button from waking phone
,
samsung galaxy s5 deactivate wake on home
,
????????? ?????? home
Click on a term to search for related topics.